Κάθε ερώτημα πρέπει να περιλαμβάνει σύνδεσμο προς τον ιστότοπο όπου εμφανίζεται το συζητούμενο ζήτημα. Καμία δημοσίευση που περιλαμβάνει σύνδεσμο προς ιστότοπο για σχολιασμό ή επίλυση προβλήματος δεν πρόκειται να διαγραφεί ό,τι κι αν συνεπάγεται αυτό για τα αποτελέσματα των μηχανών αναζήτησης ή τις σχέσεις με τους πελάτες σας. Διαβάστε τους κανόνες δεοντολογίας πριν δημοσιεύσετε.

Πρόβλημα με την ταξινόμιση πίνακα μέσα σε παράθυρο modal!!!

Πρόβλημα με την ταξινόμιση πίνακα μέσα σε παράθυρο modal!!!

ΔημοσίευσηΔημοσιεύθηκε από τον/την SophieZ » 23 Δεκ 2012, 20:37

Καλησπέρα σας... Έχω πρόβλημα με ένα component, το οποίο φορτώνω μέσω modal window. Χρησιμοποιώ το Alpha User Points, το οποίο μέσω κάποιου δικού του component, εμφανίζει μια λίστα με όλους τους χρήστες του site. Αν δεν το ανοίξω μέσω του modal window, όλα λειτουργούν κανονικά. Όταν όμως το ανοίγω μέσω modal window, δεν λειτουργεί η ταξινόμηση του πίνακα ο οποίος περιέχει τους χρήστες. Από ότι πρόσεξα, όταν περνάω με το mouse πάνω από τις επικεφαλίδες του πίνακα οι οποίες μπορούν να ταξινομηθούν, ως ενέργεια μου εμφανίζει αυτό...
Κώδικας: Επιλογή όλων
javascript:tableOrdering('aup.referreid','asc','');
Αν το κάνω ενώ το έχω ανοίξει μέσω του modal window, μου το εμφανίζει έτσι...
Κώδικας: Επιλογή όλων
javascript:tableOrdering('aup.referreid','asc','');?ml=1
Κάνοντας επεξεργασία στο συγκεκριμένο κομμάτι με το Firebug, διαγράφω το κομμάτι ?ml=1 και έτσι λειτουργεί κανονικά ακόμα και μέσα στο modal window. Πράγμα που σημαίνει ότι αυτό που φταίει και δεν λειτουργεί το component μέσα στο modal window, είναι αυτή η κατάληξη η οποία ειλικρινά δεν γνωρίζω από που προστίθεται... Έχει κανείς ιδέα τι μπορώ να κάνω προκειμένου να αφαιρέσω το συγκεκριμένο κομμάτι από την ενέργεια του ordering??? Έχουμε ψάξει σε ότι forum μπορείτε να φανταστείτε και δεν μπορούμε να βρούμε τίποτα!!! :'(

Σας ευχαριστώ εκ των προτέρων!!!
Άβαταρ μέλους
SophieZ
Δημοσιεύσεις: 5
Εγγραφή: 25 Ιουν 2012, 15:39
Τοποθεσία: Athens - Greece

Re: Πρόβλημα με την ταξινόμιση πίνακα μέσα σε παράθυρο modal

ΔημοσίευσηΔημοσιεύθηκε από τον/την pmik76 » 23 Δεκ 2012, 22:24

Πιθανότατα ο κώδικας αυτός να φορτώνεται από τα javascripts του alpha user points και πιθανότατα αυτά τα js αρχεία να είναι minified, οπότε ένα text search στους καταλόγους τους να μην βγάζει αποτέλεσμα. Δοκίμασε να τα κάνεις unminify (πχ. από εδώ http://jsbeautifier.org/) και ψάξε για το ?ml=1
Don't reinvent the wheel...
http://www.dynasource.gr
pmik76
Δημοσιεύσεις: 227
Εγγραφή: 17 Ιούλ 2011, 11:45
Τοποθεσία: Athens, GREECE


Επιστροφή στoν Components τρίτων κατασκευαστών

Συνδεδεμένα μελη

Συνδεδεμένοι: csts, leva